KODI Fanklub Polska

Witamy, Gość
Nazwa użytkownika: Hasło: Zapamiętaj mnie
Zanim zgłosisz błąd lub pomysł na poprawkę do KODI Toolbox (XTB)
Sprawdź bugtracker: kodi.org.pl/nasze-projekty/xtb-issue-tracker

TEMAT: XTB Nie działa (problem z .NET Framework)

XTB Nie działa (problem z .NET Framework) 2011/12/13 23:52 #15

  • Pawcio
  • Junior
  • Pawcio
  • Offline
  • Postów: 4
  • Pomógł: 0

U mnie nie działa (win7 64bit net Framework 4) wersja z tego miejsca www.programosy.pl/program,net-framework.html. Przed uruchomieniem wyskakuje błąd (opis poniżej) program się wprawdzie mimo to uruchamia, ale po ustawianiu bazy i źródła z filmami Get data znowu wywala kolejny błąd

Błąd przy uruchamianiu
imageshack.us/photo/my-images/846/erroram.jpg/

See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.
 
************** Exception Text **************
System.IO.FileNotFoundException: Could not load file or assembly 'System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. Nie można odnaleźć określonego pliku.
File name: 'System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'
   at xbmc.org.pl.HtmlEncoding.HTMLtoUtf(String input)
   at xbmc.org.pl.Form1.Form1_Load(Object sender, EventArgs e)
   at System.Windows.Forms.Form.OnLoad(EventArgs e)
   at System.Windows.Forms.Form.OnCreateControl()
   at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
   at System.Windows.Forms.Control.CreateControl()
   at System.Windows.Forms.Control.WmShowWindow(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   at System.Windows.Forms.Form.WmShowWindow(Message& m)
   at System.Windows.Forms.Form.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
 
WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
 
 
 
************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
xmbcToolbox
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/XBMC%20ToolBox/xmbcToolbox.exe
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Data
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_32/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
 
************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.
 
For example:
 
 
 
 
 
When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.
Ostatnio zmieniany: 2011/12/14 05:56 przez Maciey. Powód: Zbyt dlugi post - nalezy uzyc znacznikow code
Administrator wyłączył możliwość publicznego pisania postów.

Odp:XTB - Pytania i dpowiedzi (Q&A) 2011/12/14 00:05 #16

  • Pawcio
  • Junior
  • Pawcio
  • Offline
  • Postów: 4
  • Pomógł: 0

A to błąd Get data
imageshack.us/photo/my-images/190/error2c.jpg/
See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.
 
************** Exception Text **************
System.IO.FileLoadException: Mixed mode assembly is built against version 'v2.0.50727' of the runtime and cannot be loaded in the 4.0 runtime without additional configuration information.
   at xbmc.org.pl.SQLite_Utils.GetDataTable(String dbFilePath, String sql)
   at xbmc.org.pl.Form1.GetMoviesFromFolder(String folderName)
   at xbmc.org.pl.Form1.button8_Click(Object sender, EventArgs e)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
 
 
************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
xmbcToolbox
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/XBMC%20ToolBox/xmbcToolbox.exe
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Data
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_32/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
 
************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.
 
For example:
 
<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>
 
When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.



Ostatnio zmieniany: 2011/12/14 05:56 przez Maciey. Powód: Zbyt dlugi post - nalezy uzyc znacznikow code
Administrator wyłączył możliwość publicznego pisania postów.

Odp:XTB - Pytania i dpowiedzi (Q&A) 2011/12/14 16:41 #18

  • Maciey
  • Senior
  • Maciey
  • Offline
  • Postów: 1213
  • Pomógł: 85

  • KODI: Kodi 14.0 “Helix”
  • OS: W7-64, OpenElec
  • NAS: Tak
  • MySQL: Tak
  • Sterowanie: Logitech 300i
  • HTPC: PC (SSD,AMD, RADEON) + RPi
Sprawdziłem właśnie na Windows 7 64bit i działa bez problemu. Czy komukolwiek działa na W7 64bit?

Mam pare pomysłów i sprawdzę jeszcze, w międzyczasie sprawdź czy czasem to nie pomoże:
mikaelkoskinen.net/image.axd?picture=unblock_thumb.png
Zanim zapytasz - czytaj: TO. Logi wklejaj TUTAJ.
Administrator wyłączył możliwość publicznego pisania postów.

Odp:XTB - Pytania i dpowiedzi (Q&A) 2011/12/14 20:24 #19

  • Pawcio
  • Junior
  • Pawcio
  • Offline
  • Postów: 4
  • Pomógł: 0

Niestety nie mam na dysku takiego pliku nservicebus.host.exe. Nie wiem z jakim programem on się instaluje, z toolboxem, .NETFrameworkiem, czy może jakimś innym?
Może rzeczywiście mam jakiś błąd w systemie bo od półtorej roku nie był formatowany dysk na którym on się znajduje. Niemniej to pierwszy taki przypadek, że coś mi nie działa.
Administrator wyłączył możliwość publicznego pisania postów.

Odp:Odp:XTB - Pytania i dpowiedzi (Q&A) 2011/12/14 23:24 #20

  • Maciey
  • Senior
  • Maciey
  • Offline
  • Postów: 1213
  • Pomógł: 85

  • KODI: Kodi 14.0 “Helix”
  • OS: W7-64, OpenElec
  • NAS: Tak
  • MySQL: Tak
  • Sterowanie: Logitech 300i
  • HTPC: PC (SSD,AMD, RADEON) + RPi
Niestety nie mam na dysku takiego pliku nservicebus.host.exe. Nie wiem z jakim programem on się instaluje, z toolboxem, .NETFrameworkiem, czy może jakimś innym?
Może rzeczywiście mam jakiś błąd w systemie bo od półtorej roku nie był formatowany dysk na którym on się znajduje. Niemniej to pierwszy taki przypadek, że coś mi nie działa.

Nie chodzilo mi o ten plik tylko abys zeobił analogicznie z plikiem xbmcToolbox.exe (domyslnie w C:\Program Files\XBMC ToolBox)


Wrzuciłem właśnie nową wersję 0.2.1 Beta - powinno pomóc na Twoje bolączki.
Zanim zapytasz - czytaj: TO. Logi wklejaj TUTAJ.
Ostatnio zmieniany: 2011/12/15 00:03 przez Maciey.
Administrator wyłączył możliwość publicznego pisania postów.

Odp:XTB - Pytania i odpowiedzi (Q&A) 2012/01/01 21:08 #25

  • jackluk
  • Junior
  • jackluk
  • Offline
  • Postów: 2
  • Pomógł: 0

Niestety ja mam identyczne objawy jak opisane przez "Pawcio" we wcześniejszych postach. Nie mogę uruchomić wersji XBMC Toolbox 0.3.1 Beta w Win7 64bit PL Net Framework 4.
Administrator wyłączył możliwość publicznego pisania postów.

Odp:XTB - Pytania i odpowiedzi (Q&A) 2012/01/01 22:51 #26

  • Maciey
  • Senior
  • Maciey
  • Offline
  • Postów: 1213
  • Pomógł: 85

  • KODI: Kodi 14.0 “Helix”
  • OS: W7-64, OpenElec
  • NAS: Tak
  • MySQL: Tak
  • Sterowanie: Logitech 300i
  • HTPC: PC (SSD,AMD, RADEON) + RPi
Myslalem ze zostalo to naprawione w 0.2.1 - nie bylo info od @Pawco zeby nadal nie dzialalo...<br />A czy wersja 0.2.1 dziala u Ciebie?<br /><br />Rozumiem ze podobnie jak @Pawcio masz error na starce i przy GetData ?


Sprawdz tez proszę czy uruchaia Ci sie Internet Explorer
(gdy uzywasz innej przeglądarki może się okazać że są np jakieś update czekające do uruchomienia czy cos)

EDIT
Kurcze nie mam pojęcia dlaczego Wam to nie dziala! Czy macie pociągnięte najnowsze Update'y Windows?

Sprawdzilem na 3 maszynach z w7 64 bit i wszedzie dziala!
Zanim zapytasz - czytaj: TO. Logi wklejaj TUTAJ.
Ostatnio zmieniany: 2012/01/02 14:25 przez Maciey.
Administrator wyłączył możliwość publicznego pisania postów.

Odp:Odp:Odp:XTB - Pytania i dpowiedzi (Q&A) 2012/01/03 22:35 #33

  • jackluk
  • Junior
  • jackluk
  • Offline
  • Postów: 2
  • Pomógł: 0

Wersja 0.2.1 nie działa - objawy te same.<br /><br />Internet Explorer 9 działa u mnie normalnie. Update'y windowsa również zainstalowane.
Administrator wyłączył możliwość publicznego pisania postów.

Dostęp do plików Linuxa z Windowsa 2012/01/04 05:25 #34

  • szaman154
  • Junior
  • szaman154
  • Offline
  • Postów: 5
  • Pomógł: 0

wersja 0.3.1 Beta i błąd ten sam mam win 7 32 bit
I mam jeszcze jedno pytanie ponieważ mam XBMC zainstalowane na Ubuntu jako HTPC i dostęp do plików mam z poziomu Win 7
i chcę zrobić porządek w bibliotece na Ubuntu to czy z poziomu Windowsa też da się to zrobić?



Panowie temat nieaktualny , jak zwykle myślałem , że mam zainstalowane Microsoft .NET Framework a tu jednak nie.
Zainstalowałem i program jak na razie działa wyśmienicie.
Pozdrawiam.
Ostatnio zmieniany: 2012/01/04 06:49 przez szaman154. Powód: własna głupota
Administrator wyłączył możliwość publicznego pisania postów.

Odp:Odp:Odp:XTB - Pytania i dpowiedzi (Q&A) 2012/01/10 11:31 #39

  • Pawcio
  • Junior
  • Pawcio
  • Offline
  • Postów: 4
  • Pomógł: 0

U mnie pomogło dopiero skorzystanie z tak zwanego web instalatora - (instalator kilkaset kilobajtów) z tego miejsca:
www.microsoft.com/downloads/pl-pl/detail...91-b0e5-b386f32c0992
Wersja tak zwana .NET Framework 4 Client Profile (kilkadziesiąt megabajtów) u mnie nie działała właściwie z toolboxem
Ostatnio zmieniany: 2012/01/10 11:53 przez Pawcio.
Administrator wyłączył możliwość publicznego pisania postów.

Odp:Odp:Odp:Odp:XTB - Pytania i dpowiedzi (Q&A) 2012/01/10 17:17 #40

  • Maciey
  • Senior
  • Maciey
  • Offline
  • Postów: 1213
  • Pomógł: 85

  • KODI: Kodi 14.0 “Helix”
  • OS: W7-64, OpenElec
  • NAS: Tak
  • MySQL: Tak
  • Sterowanie: Logitech 300i
  • HTPC: PC (SSD,AMD, RADEON) + RPi
Racja, powinienem byl napisac ze program pracuje z wersja FULL .NETa a nie Client Profile
Zanim zapytasz - czytaj: TO. Logi wklejaj TUTAJ.
Administrator wyłączył możliwość publicznego pisania postów.
Moderatorzy: Regss, zet120, Admin
Zasilane przez Forum Kunena :: Diseño Zaragoza

Aby kontynuować, pokaż nam kim jesteś