KODI Fanklub Polska

Witamy, Gość
Nazwa użytkownika: Hasło: Zapamiętaj mnie
Zanim zgłosisz błąd lub pomysł na poprawkę do KODI Toolbox (XTB)
Sprawdź bugtracker: kodi.org.pl/nasze-projekty/xtb-issue-tracker

TEMAT: Złe nazwy katalogów.

0.6.2 beta błąd przy tworzeniu katalogów 2012/05/23 20:35 #1128

  • djwozik79
  • Bywalec
  • djwozik79
  • Offline
  • Postów: 256
  • Pomógł: 7

  • KODI: 17.1
  • OS: win7/win10/android
  • NAS: tak
  • MySQL: nie
  • HTPC: Termaltake 202, 450gts , 4gb ram, 2 x4 955/ intel stick 2/32 oraz s6 edge plus
Wysypuje się gdy w nazwie pliku mamy zawarte "`".
System.ArgumentException: Niedozwolone znaki w ścieżce.
Administrator wyłączył możliwość publicznego pisania postów.

0.6.2 beta błąd przy tworzeniu katalogów 2012/05/23 22:09 #1129

  • Maciey
  • Senior
  • Maciey
  • Offline
  • Postów: 1213
  • Pomógł: 89

  • KODI: Kodi 14.0 “Helix”
  • OS: W7-64, OpenElec
  • NAS: Tak
  • MySQL: Tak
  • Sterowanie: Logitech 300i
  • HTPC: PC (SSD,AMD, RADEON) + RPi
A dokładniej - którą funkcję masz na mysli ?
Możesz załaczyć szczegóły błędu ?



Zanim zapytasz - czytaj: TO. Logi wklejaj TUTAJ.
Administrator wyłączył możliwość publicznego pisania postów.

0.6.2 beta błąd przy tworzeniu katalogów 2012/05/23 22:26 #1131

  • djwozik79
  • Bywalec
  • djwozik79
  • Offline
  • Postów: 256
  • Pomógł: 7

  • KODI: 17.1
  • OS: win7/win10/android
  • NAS: tak
  • MySQL: nie
  • HTPC: Termaltake 202, 450gts , 4gb ram, 2 x4 955/ intel stick 2/32 oraz s6 edge plus
przenieś film do osobnego folderu
jeżeli bardzo zależy ci na szczegółach to odtworzę ten przypadek.
Administrator wyłączył możliwość publicznego pisania postów.

0.6.2 beta błąd przy tworzeniu katalogów 2012/05/25 21:41 #1141

  • djwozik79
  • Bywalec
  • djwozik79
  • Offline
  • Postów: 256
  • Pomógł: 7

  • KODI: 17.1
  • OS: win7/win10/android
  • NAS: tak
  • MySQL: nie
  • HTPC: Termaltake 202, 450gts , 4gb ram, 2 x4 955/ intel stick 2/32 oraz s6 edge plus
Kolejnym problem chyba spowodowany scraperem bądź językiem.
Źle zidentyfikował filmy w xbmc w wyniku czego XTB przy tworzeniu katalogów z nazw plików dodanych do xbmc zrobił :
Splice 2009 5.1 - xtb nazwał katalog Sice (2009) 5 1
Johnny English 2 Reborn 2011 5.1 - Johnnylish 2 reborn (2011)
Grey 2011 cd1 5.1 i Grey 2011 cd2 5.1 - zrobił 2 oddzielne katalogi Grey (2011) cd1 5 1 i Grey (2011) cd1 5 1, a film w xbmc zidentyfikował jako Chitkabrey
Entitled 2011 5.1 w xbmc zidentyfikował i nazwał jako The Entitled (wcześniej nigdy nie dawał The)
Administrator wyłączył możliwość publicznego pisania postów.

0.6.2 beta błąd przy tworzeniu katalogów 2012/05/26 07:29 #1143

  • Maciey
  • Senior
  • Maciey
  • Offline
  • Postów: 1213
  • Pomógł: 89

  • KODI: Kodi 14.0 “Helix”
  • OS: W7-64, OpenElec
  • NAS: Tak
  • MySQL: Tak
  • Sterowanie: Logitech 300i
  • HTPC: PC (SSD,AMD, RADEON) + RPi
Dawid napisał:
przenieś film do osobnego folderu
jeżeli bardzo zależy ci na szczegółach to odtworzę ten przypadek.


Próbowałem:
1. stworzyc plik z apostrofem w nazwie
2. z zakładki foldery wybrałem opcje 'Przenies film do osobnego folderu'

I nic sie nie wywalilo...

Tak więc proszę o podanie kroków abym mógł je powtórzyć u siebie + zalaczenie kilku pierwszych linijek ze szczegółów błedu
Zanim zapytasz - czytaj: TO. Logi wklejaj TUTAJ.
Administrator wyłączył możliwość publicznego pisania postów.

0.6.2 beta błąd przy tworzeniu katalogów 2012/05/26 08:11 #1144

  • djwozik79
  • Bywalec
  • djwozik79
  • Offline
  • Postów: 256
  • Pomógł: 7

  • KODI: 17.1
  • OS: win7/win10/android
  • NAS: tak
  • MySQL: nie
  • HTPC: Termaltake 202, 450gts , 4gb ram, 2 x4 955/ intel stick 2/32 oraz s6 edge plus
Próbuje odtworzyć i nie mogę ...
ha !, to nie był ` a ' :)
Uwaga: Spoiler! [ Kliknij, aby rozwinąć ]
Administrator wyłączył możliwość publicznego pisania postów.

Złe nazwy katalogów. 2012/09/23 19:25 #1861

  • djwozik79
  • Bywalec
  • djwozik79
  • Offline
  • Postów: 256
  • Pomógł: 7

  • KODI: 17.1
  • OS: win7/win10/android
  • NAS: tak
  • MySQL: nie
  • HTPC: Termaltake 202, 450gts , 4gb ram, 2 x4 955/ intel stick 2/32 oraz s6 edge plus
Przy przenoszenie plików do katalogów czasami niepotrzebnie dodaje mi dopisek po roku np :
plik - ATM 2012 5.1
kat - Atm (2012) 5 1
plik - LOL 2012 5.1
kat - Lol (2012) 5 1

a pozostałe nazwy katalogów są normalne, czyli kończą się na roku.

Chyba jest problem gdy są krótkie nazwy plików.Jak dobrze pamiętam to dopisywał też inne części nazwy, przykładu nie mam ale chyba dopisywał też PL np przy nazwie pliku Dom 1999 PL

Dodatkowo przy pliku:
five-year Engagement 2012
tworzy kat - Five bez reszty tytułu i roku, a po wykasowaniu "-" tworzy
Five yearagement (2012) pisane razem jak widać i nie jest to cały tytuł.
Ostatnio zmieniany: 2012/10/07 01:12 przez Maciey.
Administrator wyłączył możliwość publicznego pisania postów.

Odp: Złe nazwy katalogów. 2012/09/23 21:32 #1865

  • Maciey
  • Senior
  • Maciey
  • Offline
  • Postów: 1213
  • Pomógł: 89

  • KODI: Kodi 14.0 “Helix”
  • OS: W7-64, OpenElec
  • NAS: Tak
  • MySQL: Tak
  • Sterowanie: Logitech 300i
  • HTPC: PC (SSD,AMD, RADEON) + RPi
Dzięki - zerknę
Zanim zapytasz - czytaj: TO. Logi wklejaj TUTAJ.
Administrator wyłączył możliwość publicznego pisania postów.

Odp: Złe nazwy katalogów. 2012/09/27 18:10 #1916

  • djwozik79
  • Bywalec
  • djwozik79
  • Offline
  • Postów: 256
  • Pomógł: 7

  • KODI: 17.1
  • OS: win7/win10/android
  • NAS: tak
  • MySQL: nie
  • HTPC: Termaltake 202, 450gts , 4gb ram, 2 x4 955/ intel stick 2/32 oraz s6 edge plus
Gdy w tytule znajduje się - nazwę katalogu tworzy tylko z tego co było przed minusem i nie podaje roku.
U-571 2000
stworzony katalog to U

Gdy w tytule na początku mamy rok jak np:
1911 Revolution 2011 2.0 sub
to tworzy katalog
(1911) Revolution 2011 2.0 sub
zamiast
1911 Revolution (2011)

` temat juz kiedyś poruszany, gdy w nazwie mamy znaczek ` np what`s to program się wysypuje

dodano :
Playback 2012 5.1 sub stworzył Ayback (2012)
Best Laid Plans 2012 5.1 sub stworzył Best laid ans (2012) :)
czyli kasuje Pl językowe, ale nie zawsze, bo np : plague zrobił dobrze
Ostatnio zmieniany: 2012/10/05 18:36 przez djwozik79.
Administrator wyłączył możliwość publicznego pisania postów.

Odp: Złe nazwy katalogów. 2012/10/07 01:10 #2025

  • Maciey
  • Senior
  • Maciey
  • Offline
  • Postów: 1213
  • Pomógł: 89

  • KODI: Kodi 14.0 “Helix”
  • OS: W7-64, OpenElec
  • NAS: Tak
  • MySQL: Tak
  • Sterowanie: Logitech 300i
  • HTPC: PC (SSD,AMD, RADEON) + RPi
Wszystkie wymienione problemy z nazwami katalogów poprawiono (mam nadzieję) w wersi 0.7.2B:
[FIX] Poprawiono automatyke korekcji nazw przy tworzeniu katalogów na podstawie nazw plików
Zanim zapytasz - czytaj: TO. Logi wklejaj TUTAJ.
Administrator wyłączył możliwość publicznego pisania postów.
Moderatorzy: Regss, zet120, Admin
Zasilane przez Forum Kunena :: Diseño Zaragoza

Aby kontynuować, pokaż nam kim jesteś