KODI Fanklub Polska

Witamy, Gość
Nazwa użytkownika: Hasło: Zapamiętaj mnie
  • Strona:
  • 1
  • 2
  • 3

TEMAT: Raspberry PI. Praca z USB

Raspberry PI. Praca z USB 2013/09/05 05:49 #5839

  • Zbychu
  • Senior
  • Zbychu
  • Offline
  • Postów: 871
  • Pomógł: 74

  • KODI: Najnowsza Beta
  • OS: OpenElec, W7-64
  • NAS: TAK
  • MySQL: TAK
  • Sterowanie: Piloty: Logitech 300i, Medion x10, Key: Logitech k400, Android Remore: Yatse
  • HTPC: 2xPC + RPi, czasem Android


Jak wiadomo typowa instalacja Systemu Operacyjnego na Raspberry PI używa karty SD.

Takie rozwiązanie ma swoje plusy i minusy. Plusem jest oczywiście miniaturyzacja, ew. koszt, minusem zaś czas dostępu, podatność na błędy (zwłaszcza przy tzw „podkręcaniu” urządzenia).

W artykule przedstawimy w jaki sposób można przenieść cześć zasobów na USB pendrive, czyniąc system bardziej wydajnym i odpornym na błędy.

Czytaj więcej...
Administrator wyłączył możliwość publicznego pisania postów.

Raspberry PI. Praca z USB 2013/09/05 14:41 #5840

  • Piter
  • Autor Artykułów
  • Piter
  • Offline
  • Postów: 558
  • Pomógł: 36

  • KODI: Ostatni stabilny
  • OS: W10, OpenElec, Android, RRi
  • NAS: TAK
  • MySQL: TAK
  • Sterowanie: Logitech 300i, Logitech K400
  • HTPC: HTPC + RPi
Dzięki @Zbychu. Już kiedyś za twoja poradą przeniosłem się na USB i moja Malina jakby dostała nitro do baku :)

Wszystkim szczerze polecam to rozwiązanie (zwłaszcza tym którzy jak ja maja bibliotekę na PI + NASa z materiałami video)



Administrator wyłączył możliwość publicznego pisania postów.

Raspberry PI. Praca z USB 2013/09/14 20:22 #5990

  • Lord Viadro
  • Junior
  • Lord Viadro
  • Offline
  • Postów: 20
  • Pomógł: 0

  • KODI: 13
  • OS: openelec 4
  • Sterowanie: CEC Pilot, Klawiatura
Udało mi się odpalić system z pendriva i teraz chciałbym odzyskać kartę, która mam w raspberry (16GB) i zastąpić ją starą 2GB. Czy wystarczy samo przekopiowanie plików (nie wydaje mi się)? Jeśli znacie rozwiązanie prosiłbym o info.

pozdrawiam
Ostatnio zmieniany: 2013/09/14 21:46 przez Zbychu.
Administrator wyłączył możliwość publicznego pisania postów.

Raspberry PI. Praca z USB 2013/09/14 21:51 #5991

  • Zbychu
  • Senior
  • Zbychu
  • Offline
  • Postów: 871
  • Pomógł: 74

  • KODI: Najnowsza Beta
  • OS: OpenElec, W7-64
  • NAS: TAK
  • MySQL: TAK
  • Sterowanie: Piloty: Logitech 300i, Medion x10, Key: Logitech k400, Android Remore: Yatse
  • HTPC: 2xPC + RPi, czasem Android
Przekopiowanie plikow nie wystarczy bo SD musi miec partycje rozruchową odpowiednio zamarkowaną na potrzeby systemu

Osobiscie to bym od nowa zainstalował system na 2GB karcie i skonfigurował wg uznania - to szybka pilka.

Jak Ci sie chce bawic to mozesz sprobować:
1. zainstalować identyczna wersje jak masz na 16GB na 2GB
2. przekopiowac pliki konfiguracyjne (chyba wystarczy te 2 z partycji FAT, widocznej pod Windows)

Aczkolwiek głowy nie dam. Ja po prostu instaluje od nowa :)
Administrator wyłączył możliwość publicznego pisania postów.

Raspberry PI. Praca z USB 2013/09/15 19:28 #5998

  • Lord Viadro
  • Junior
  • Lord Viadro
  • Offline
  • Postów: 20
  • Pomógł: 0

  • KODI: 13
  • OS: openelec 4
  • Sterowanie: CEC Pilot, Klawiatura
tak też zrobiłem i działa :)
ps ... użyłem jeszcze starszej 1GB karty (ze starej nokii).
Administrator wyłączył możliwość publicznego pisania postów.

Raspberry PI. Praca z USB 2013/09/15 20:03 #5999

  • Zbychu
  • Senior
  • Zbychu
  • Offline
  • Postów: 871
  • Pomógł: 74

  • KODI: Najnowsza Beta
  • OS: OpenElec, W7-64
  • NAS: TAK
  • MySQL: TAK
  • Sterowanie: Piloty: Logitech 300i, Medion x10, Key: Logitech k400, Android Remore: Yatse
  • HTPC: 2xPC + RPi, czasem Android
Ciesze się że działa.

1GB karta wraz z USB jest idealna sam tez takiej uzywam
Szkoda wkladac cokolwiek innego.
Administrator wyłączył możliwość publicznego pisania postów.

Raspberry PI. Praca z USB 2013/12/10 10:52 #6846

  • amorfic
  • Junior
  • amorfic
  • Offline
  • Postów: 16
  • Pomógł: 0

  • KODI: Gotham 13.2
  • OS: OpenElec 4.0.0
  • HTPC: ASROCK350M1
Użyłem dysku zew. Niestety 3 na 4 razy jest problem ze startem systemu ze względu na błąd w montowaniu dysku:
Error in mount_storage: mount_common: Could not mount /dev/sda1

Jakieś sugestie?

OpenElec na RPi + SD klasa 10 + dysk zew. Seagate (stacjonarny z własnym zasilaniem), zasilacz 2A,
Administrator wyłączył możliwość publicznego pisania postów.

Raspberry PI. Praca z USB 2013/12/10 11:41 #6847

  • Zbychu
  • Senior
  • Zbychu
  • Offline
  • Postów: 871
  • Pomógł: 74

  • KODI: Najnowsza Beta
  • OS: OpenElec, W7-64
  • NAS: TAK
  • MySQL: TAK
  • Sterowanie: Piloty: Logitech 300i, Medion x10, Key: Logitech k400, Android Remore: Yatse
  • HTPC: 2xPC + RPi, czasem Android
Spróbowałbm zamontować go ręcznie / uruchomić gdy sie sam w końcu podmontuje i odpalić na nim sprawdzenie dysku:
fsck
(Można też ew zrobić z jakiegoś live CD - np Ubuntu)

Jaka wersje OE używasz ?


Zobacz również:
openelec.tv/forum/133-installation/36077...-while-booting#36307
Administrator wyłączył możliwość publicznego pisania postów.
Za tę wiadomość podziękował(a): amorfic

Raspberry PI. Praca z USB 2013/12/11 10:22 #6859

  • amorfic
  • Junior
  • amorfic
  • Offline
  • Postów: 16
  • Pomógł: 0

  • KODI: Gotham 13.2
  • OS: OpenElec 4.0.0
  • HTPC: ASROCK350M1
Przeprosiłem Ubuntu i sformatowałem dysk (fsck wywalił masę błędów i nie pozwolił na użycie -a )
Na razie działa bez zarzutu.
Dzięki Zbychu
Administrator wyłączył możliwość publicznego pisania postów.

Raspberry PI. Praca z USB 2014/02/07 13:20 #7895

  • woszi
  • Junior
  • woszi
  • Offline
  • Postów: 4
  • Pomógł: 0

Witam w pierwszym moim poście na tym forum. Dotychczas czytałem i zwykle znalazłem rozwiązanie.
Przymierzałem się do skorzystania z tej metody lecz pojawiły się pewne kłopoty.
Czy ktoś skutecznie wykonał to na raspbmc?
Ostatnio zmieniany: 2014/02/07 13:21 przez woszi.
Administrator wyłączył możliwość publicznego pisania postów.

Raspberry PI. Praca z USB 2014/02/08 09:35 #7906

  • Zbychu
  • Senior
  • Zbychu
  • Offline
  • Postów: 871
  • Pomógł: 74

  • KODI: Najnowsza Beta
  • OS: OpenElec, W7-64
  • NAS: TAK
  • MySQL: TAK
  • Sterowanie: Piloty: Logitech 300i, Medion x10, Key: Logitech k400, Android Remore: Yatse
  • HTPC: 2xPC + RPi, czasem Android
woszi napisał:
Witam w pierwszym moim poście na tym forum. Dotychczas czytałem i zwykle znalazłem rozwiązanie.
Przymierzałem się do skorzystania z tej metody lecz pojawiły się pewne kłopoty.
Czy ktoś skutecznie wykonał to na raspbmc?

Jakie kłopoty ? Napisz więcej jeżeli chcesz abyśmy Ci pomogli...
Administrator wyłączył możliwość publicznego pisania postów.

Raspberry PI. Praca z USB 2014/02/08 13:15 #7909

  • woszi
  • Junior
  • woszi
  • Offline
  • Postów: 4
  • Pomógł: 0

Przy próbie podmontowania po formatowaniu sytuacja wygląda tak:

pi@raspbmc:~$ mount /dev/sda1 /var/media/
mount: only root can do that
pi@raspbmc:~$ sudo mount /dev/sda1 /var/media/
mount: mount point /var/media/ does not exist
pi@raspbmc:~$


df -h zwraca:

pi@raspbmc:~$ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/mmcblk0p2 7.3G 1000M 6.0G 15% /
/dev/mmcblk0p1 69M 8.2M 61M 12% /boot


No to na skróty wyjmuję i wkładam pendrive:


pi@raspbmc:~$ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/mmcblk0p2 7.3G 1000M 6.0G 15% /
/dev/mmcblk0p1 69M 8.2M 61M 12% /boot
/dev/sda1 15G 38M 14G 1% /media/Storage

Skoro tak to zmieniam punkt montowania:

pi@raspbmc:~$ umount /dev/sda1
pi@raspbmc:~$ sudo mount /dev/sda1 /media/Storage
mount: mount point /media/Storage does not exist

Jak widać pomimo że "z automatu" się montuje mount informuje że takiego punktu nie ma.


No ale podążajmy dalej. Wyjmuję i wkładam pendrive, montuje się automatycznie i mamy:

pi@raspbmc:~$ cp -r /storage/. /var/media/
cp: cannot stat `/storage/.': No such file or directory

jako sudo to samo

i w sumie moja zabawa w tym miejscu się kończy :(

Z ciekawości zainstalowałem na drugiej karcie openelec i wszystko poszło "od strzału"
Administrator wyłączył możliwość publicznego pisania postów.

Raspberry PI. Praca z USB 2014/02/08 17:34 #7912

  • squallpolska
  • Bywalec
  • squallpolska
  • Offline
  • Postów: 155
  • Pomógł: 14

  • KODI: 21.37
A foldery do których montujesz istnieją?
Administrator wyłączył możliwość publicznego pisania postów.

Raspberry PI. Praca z USB 2014/02/08 17:44 #7913

  • woszi
  • Junior
  • woszi
  • Offline
  • Postów: 4
  • Pomógł: 0

Zwróć uwagę na wynik df -h. Tam montuje się automatycznie, natomiast po umount wydanie komendy mount do tego punktu wywala wynik że nie istnieje. Dla mnie maluczkiego co najmniej dziwne.

Co powiesz na wynik ostatniego polecenia?

Może inaczej.
W jaki sposób sprawdzić strukturę katalogów? I najlepiej ich zawartość ;-)
Administrator wyłączył możliwość publicznego pisania postów.

Raspberry PI. Praca z USB 2014/02/08 17:57 #7914

  • squallpolska
  • Bywalec
  • squallpolska
  • Offline
  • Postów: 155
  • Pomógł: 14

  • KODI: 21.37
Sprawdzasz poleceniem ls...

Zrób katalog i tam zamontuj dane urządzenie.
Administrator wyłączył możliwość publicznego pisania postów.

Raspberry PI. Praca z USB 2014/02/08 20:09 #7915

  • woszi
  • Junior
  • woszi
  • Offline
  • Postów: 4
  • Pomógł: 0

Katalogi utworzyłem dla pendrive oraz /var/media bo też go nie było.
Pendrak podmontowany z mount tak jak należy
Wszystko jako root.

teraz kolejne pytanie: co z
cp -r /storage/. /var/media/

w jakim katalogu wykonać?

zwraca komunikat w głównym i home:

cp: cannot stat `/storage/.': No such file or directory
Administrator wyłączył możliwość publicznego pisania postów.

Raspberry PI. Praca z USB 2014/02/08 20:35 #7917

  • squallpolska
  • Bywalec
  • squallpolska
  • Offline
  • Postów: 155
  • Pomógł: 14

  • KODI: 21.37
Nie wiem co chcesz skopiować. Polecenie zwraca, że nie ma folderu /storage
Administrator wyłączył możliwość publicznego pisania postów.

Raspberry PI. Praca z USB 2014/02/09 21:46 #7929

  • Zbychu
  • Senior
  • Zbychu
  • Offline
  • Postów: 871
  • Pomógł: 74

  • KODI: Najnowsza Beta
  • OS: OpenElec, W7-64
  • NAS: TAK
  • MySQL: TAK
  • Sterowanie: Piloty: Logitech 300i, Medion x10, Key: Logitech k400, Android Remore: Yatse
  • HTPC: 2xPC + RPi, czasem Android
Artykuł opisuje instalację pod OpenElec - dlatego nie możesz wykonać z sukcesem tych samych poleceń na innej dystrybucji.
(Prawdopodobnie nie ma tam np folderu Storage)

W chwili obecnej nie mam czasu zobaczyć jak to wygląda na Raspbmc czy innych systemach - ale musisz postąpić analogicznie zamieniając jedynie ścieżki

Aby sie przekonać gdzie co masz zainstaluj sobie np Midnight Commander
sudo apt-get update && sudo apt-get upgrade
sudo apt-get install mc  


uruchamiasz pozniej wpisując
mc
Ostatnio zmieniany: 2014/02/09 21:47 przez Zbychu.
Administrator wyłączył możliwość publicznego pisania postów.

Raspberry PI. Praca z USB 2014/10/24 19:23 #9976

  • gregory128
  • Junior
  • gregory128
  • Offline
  • Postów: 17
  • Pomógł: 0

Witam,

Kurcze nie moge sobie z tym poradzić na raspbmc.
Czy mogę prosić o łopatologiczne wytłumaczenie tematu dla raspbmc.

dziękuje

gregory128
Administrator wyłączył możliwość publicznego pisania postów.

Raspberry PI. Praca z USB 2014/10/25 16:52 #9982

  • Piter
  • Autor Artykułów
  • Piter
  • Offline
  • Postów: 558
  • Pomógł: 36

  • KODI: Ostatni stabilny
  • OS: W10, OpenElec, Android, RRi
  • NAS: TAK
  • MySQL: TAK
  • Sterowanie: Logitech 300i, Logitech K400
  • HTPC: HTPC + RPi
A czy czasem Raspbmc nie ma tej opcji juz podczas instalowania ?

PS Najlepiej przeskakuj na OE. Przetestowałem z 5 roznych distro i OE rulez!
Administrator wyłączył możliwość publicznego pisania postów.
  • Strona:
  • 1
  • 2
  • 3
Moderatorzy: Regss, zet120, Admin
Zasilane przez Forum Kunena :: Diseño Zaragoza

Aby kontynuować, pokaż nam kim jesteś