KODI Fanklub Polska

Witamy, Gość
Nazwa użytkownika: Hasło: Zapamiętaj mnie
Zanim zadasz pytanie upewnij się że przeczytałeś: kodi.org.pl/index.php/component/content/...nim-zaczniesz-z-xbmc

Uprzejmie prosimy o szczegółowe nadawanie nazwy tematu, by potem łatwo można było go znaleźć w wyszukiwarce ;-) Pamiętaj, że swoim tematem możesz pomóc komuś, kto będzie miał taki sam problem.

TEMAT: Brak okładek filmów

Brak okładek filmów 2013/09/15 22:07 #6002

  • Upsa
  • Junior
  • Upsa
  • Offline
  • Postów: 8
  • Pomógł: 0

Mam komputer z OpenElec 3.0.6, XBMC 12.2 Frodo, skóra Confluence 2.1.5, do tego zainstalowane m.in. wtyczki: Filmweb Lite 1.2.5, The TVDB 1.5.4. Po dodaniu filmów i seriali (każdy w osobnym katalogu) system przeskanował całe zasoby i ściągnął poprawnie polskie nazwy filmów, opisy, obsadę itp. Natomiast przeglądając filmy (widok FanArt) nie wyświetlają się okładki filmów - są tylko czarne prostokąty (jak na screenie). W katalogach z filmami nie ma plików folder.jpg, a używając wtyczki Artwork Downloader 12.019 ściągają mi się rozmaite fanarty, miniatury, banery itp (które - notabene - nijak nie są wykorzystywane podczas przeglądania listy filmów lub szczegółów danego filmu).
Co mogę mieć źle ustawione, że okładki się nie ściągają, a fanarty nie są wykorzystywane?

Ostatnio zmieniany: 2013/09/17 01:08 przez Maciey.
Administrator wyłączył możliwość publicznego pisania postów.

Brak okładek filmów 2013/09/17 01:12 #6016

  • Piter
  • Autor Artykułów
  • Piter
  • Offline
  • Postów: 561
  • Pomógł: 59

  • KODI: Ostatni stabilny
  • OS: W10, OpenElec, Android, RRi
  • NAS: TAK
  • MySQL: TAK
  • Sterowanie: Logitech 300i, Logitech K400
  • HTPC: HTPC + RPi
Po pierwsze masz troche starawy ten Open Elec - w chwili obecnej dostępna jest chyba wersja 3.2 9stabilna) jeżeli dobrze pamiętam

po drugie mozesz sprobowac wycziscic cache plikow - recznie lub korzystajać z pluginu - np




Administrator wyłączył możliwość publicznego pisania postów.

Brak okładek filmów 2013/09/17 08:12 #6018

  • Regss
  • MODERATOR
  • Regss
  • Offline
  • Postów: 584
  • Pomógł: 96

  • KODI: XBMC 13 Gotham
  • OS: Windows 7 x64
  • NAS: Nie
  • MySQL: Tak
  • Sterowanie: Medion X10, Logitech K360
Plik userdata/Database/Textures13.db i katalog Thumbinals do usunięcia. Cache odbuduje się sam.
Regss Add-ons Repository - Filmweb.pl Scraper, Movielib, Audio Profiles, Filmweb Trailery, Backup Watched, Tag Star Rating, Polskie Stacje, Show Image
Administrator wyłączył możliwość publicznego pisania postów.

Brak okładek filmów 2013/09/18 01:15 #6031

  • Upsa
  • Junior
  • Upsa
  • Offline
  • Postów: 8
  • Pomógł: 0

Piter:
Po pierwsze masz troche starawy ten Open Elec - w chwili obecnej dostępna jest chyba wersja 3.2 9stabilna) jeżeli dobrze pamiętam

po drugie mozesz sprobowac wycziscic cache plikow - recznie lub korzystajać z pluginu - np
OpenElec już się zaktualizował do najnowszej wersji, jednakże wyczyszczenie cache'a nic nie dało.
Podobnie jak działania opisane przez Regss:
Plik userdata/Database/Textures13.db i katalog Thumbinals do usunięcia. Cache odbuduje się sam.

Nie mam żadnych doświadczeń, ale - o ile dobrze zrozumiałem - żeby wyświetlały się okładki - to w katalogu filmu musi być plik folder.jpg. Jak taki plik dodałem ręcznie - to zadziałało. Ale nie uśmiecha mi się dodawanie ręcznie okładek do wszystkich filmów z kolekcji.
Ewidentnie czegoś nie zrobiłem - tylko czego??
Administrator wyłączył możliwość publicznego pisania postów.

Brak okładek filmów 2013/09/18 16:15 #6041

  • Zbychu
  • Senior
  • Zbychu
  • Offline
  • Postów: 872
  • Pomógł: 107

  • KODI: Najnowsza Beta
  • OS: OpenElec, W7-64
  • NAS: TAK
  • MySQL: TAK
  • Sterowanie: Piloty: Logitech 300i, Medion x10, Key: Logitech k400, Android Remore: Yatse
  • HTPC: 2xPC + RPi, czasem Android
Czy ty na pewno jestes w trybie biblioteki czy przeglądasz po prostu pliki ???

Bo jeżeli to jedynie pliki to faktycznie musi byc lokalnie zapisany folder.jpg
Do tego możesz użyc np naszego toola XTB
Administrator wyłączył możliwość publicznego pisania postów.

Brak okładek filmów 2013/09/18 16:57 #6043

  • Regss
  • MODERATOR
  • Regss
  • Offline
  • Postów: 584
  • Pomógł: 96

  • KODI: XBMC 13 Gotham
  • OS: Windows 7 x64
  • NAS: Nie
  • MySQL: Tak
  • Sterowanie: Medion X10, Logitech K360
Pytanie podstawowe: Czy używasz scrapera jeśli tak to jakiego i w jakiej wersji? Czy masz pliki NFO w których zawarte są informacje o poszczególnych filmach.
Regss Add-ons Repository - Filmweb.pl Scraper, Movielib, Audio Profiles, Filmweb Trailery, Backup Watched, Tag Star Rating, Polskie Stacje, Show Image
Administrator wyłączył możliwość publicznego pisania postów.

Brak okładek filmów 2013/09/18 23:35 #6047

  • Upsa
  • Junior
  • Upsa
  • Offline
  • Postów: 8
  • Pomógł: 0

Dane ściągam aktualnie scraperem Filmweb Lite 1.2.6 (niedawno zaktualizował się z wersji 1.2.5) i The TVDB 1.5.4. Plików NFO nie mam - dane pięknie są ściągane przez scrapery,
Trochę zajrzałem do logów i wyglądają ładnie (chociaż nie do końca się w nich orientuję).

Wyrywek logu dla nowo dodanego filmu:
20:29:26 T:2945305408   DEBUG: VideoInfoScanner: 
   Scanning dir '/storage/filmy/bajki/ParaNorman [2012]/' as not in the database
20:29:26 T:2945305408   DEBUG: VideoInfoScanner: 
   No NFO file found. Using title search for '/storage/filmy/bajki/ParaNorman [2012]/
   ParaNorman.2012.PLDUB.BRRip.XviD-BiDA.(osloskop.net).avi'
20:29:26 T:2945305408   DEBUG: FindMovie: Searching for 'ParaNorman' using 
   Filmweb Lite scraper (path: '/storage/.xbmc/addons/metadata.filmweb.pl-lite', 
   content: 'movies', version: '1.2.6')
...
20:29:27 T:2945305408   DEBUG: scraper: GetSearchResults returned 
   <results><entity><title>ParaNorman / ParaNorman</title><year>2012</year>
   <url cache="filmweb-599050">http://www.filmweb.pl/Film?id=599050</url></entity></results>
...
<thumb aspect="poster" preview="http://1.fwcdn.pl/po/90/50/599050/7489172.2.jpg">
   http://1.fwcdn.pl/po/90/50/599050/7489172.3.jpg</thumb
...
Czyli nie znajduje w katalogu pliku .NFO, wobec czego szuka informacji na filmweb i znajduje je - między innymi i okładkę. Co z tym potem robi - nie mam pojęcia.

A co do pytania o tryb biblioteki... To mam wrażenie, że jest włączony...

Po zmianie skóry na Transparency dalej nie widać okładek filmów, ale za to pięknie się prezentują fanarty, np:


Administrator wyłączył możliwość publicznego pisania postów.

Brak okładek filmów 2013/09/19 08:58 #6048

  • Regss
  • MODERATOR
  • Regss
  • Offline
  • Postów: 584
  • Pomógł: 96

  • KODI: XBMC 13 Gotham
  • OS: Windows 7 x64
  • NAS: Nie
  • MySQL: Tak
  • Sterowanie: Medion X10, Logitech K360
Scraper pobiera okładki prawidłowo. Jeśli używasz scraperów nie powinieneś trzymać w katalogach filmów żadnej grafiki. Dla mnie wygląda to jak problem z cache rozumiem że usunąłeś na moją prośbę plik userdata/Database/Textures13.db i katalog Thumbinals? Jeśli tak możesz spróbować usunąć również myvideo75.db ale to spowoduje usunięcie całej bazy filmów. Następnie ponownie przeskanować bibliotekę.
Regss Add-ons Repository - Filmweb.pl Scraper, Movielib, Audio Profiles, Filmweb Trailery, Backup Watched, Tag Star Rating, Polskie Stacje, Show Image
Administrator wyłączył możliwość publicznego pisania postów.

Brak okładek filmów 2013/09/19 20:46 #6056

  • Upsa
  • Junior
  • Upsa
  • Offline
  • Postów: 8
  • Pomógł: 0

No już nie wiem, o co może chodzić...
Zrobiłem wszystko, co pisałeś.
Ostatnie działanie polegało na usunięciu tych dwóch plików i katalogu, które wymieniałeś - po czym restart systemu, zdefiniowanie scrapera dla filmów, uaktualnienie biblioteki - ale to też nic nie dało (tzn ściągnęły się ładnie opisy, ale dalej okładki są puste)...
Administrator wyłączył możliwość publicznego pisania postów.

Brak okładek filmów 2013/09/20 23:25 #6064

  • Upsa
  • Junior
  • Upsa
  • Offline
  • Postów: 8
  • Pomógł: 0

Mam podejrzenie, że moje problemy wynikają z mojego sprzętu (Asus ITX-220).
Zainstalowałem OpenElec'a na pendrive i na Asusie znany objaw - brak okładek. Udało mi się odpalić tenże system na innym kompie i odświeżenie biblioteki sprawiło, że okładki pojawiły się. Ponowny start systemu na Asusie, aktualizacja biblioteki i... okładek brak.
Trochę to dziwne, nie??
Ma ktoś pomysł, o co może biegać?
Administrator wyłączył możliwość publicznego pisania postów.

Re:Brak okładek filmów 2013/09/21 11:55 #6068

  • marx
  • Autor Artykułów
  • marx
  • Offline
  • Postów: 798
  • Pomógł: 42

  • KODI: 15.2
  • OS: Linux Debian
  • NAS: Nie
  • MySQL: Tak
  • Sterowanie: Logitech Harmony
Zerknij w logi xbmc
Administrator wyłączył możliwość publicznego pisania postów.

Re:Brak okładek filmów 2013/09/21 22:58 #6075

  • Zbychu
  • Senior
  • Zbychu
  • Offline
  • Postów: 872
  • Pomógł: 107

  • KODI: Najnowsza Beta
  • OS: OpenElec, W7-64
  • NAS: TAK
  • MySQL: TAK
  • Sterowanie: Piloty: Logitech 300i, Medion x10, Key: Logitech k400, Android Remore: Yatse
  • HTPC: 2xPC + RPi, czasem Android
Albo użyj XTB niech zrobi ci folder.jpg dla każdego filmu i po zabawie...

Team kodi.org.pl podjął decyzję o stworzeniu prostej aplikacji o nazwie xbmc-toolbox (XTB), która bez dodatkowych narzędzi umożliwi posprzątanie jak i (przede wszystkim) pełne spolszczenie biblioteki XBMC.

XTB umożliwia automatyczne pobranie informacji o filmie ze strony Filmweb.pl, dane te możemy następnie dowolnie edytować. Dla nieodnalezionych treści użytownik ma możliwość wpisać wszystkie dane 'ręcznie'.

Program daje też możliwość zarządzania grafikami (fanarty, okładki) oraz dostarcza wiele innych dodatkowych funkcji związanych z utrzymaniem biblioteki w należytym porządku.

Zachęcamy do zapoznania się z serią artykułów poświęconych aplikacji / uporzadkowania biblioteki.

Czytaj więcej...
Ostatnio zmieniany: 2013/10/25 13:46 przez Zbychu.
Administrator wyłączył możliwość publicznego pisania postów.
Za tę wiadomość podziękował(a): Upsa

Re:Brak okładek filmów 2013/09/24 10:06 #6101

  • Upsa
  • Junior
  • Upsa
  • Offline
  • Postów: 8
  • Pomógł: 0

Zbychu napisał:
Albo użyj XTB niech zrobi ci folder.jpg dla każdego filmu i po zabawie...

Tak zrobiłem i po zabawie... prawie.

Prawie - bo jeszcze pozostały mi seriale. Czy jest jakieś narzędzie "w tym stylu" dla seriali?

PS. Mam coś felerny ten komp - póki co zauważyłem jeszcze, że nie wyświetlają mi się wiadomości RSS.

PS2. Logami może kiedyś się zainteresuję - póki co rozwiązanie zaproponowane przez Zbycha wystarczająco mnie satysfakcjonuje.
Administrator wyłączył możliwość publicznego pisania postów.

Brak okładek filmów 2013/10/25 10:02 #6471

  • Upsa
  • Junior
  • Upsa
  • Offline
  • Postów: 8
  • Pomógł: 0

Problem zniknął po aktualizacji OpenElec'a...

Dzięki wszystkim za pomoc!
Administrator wyłączył możliwość publicznego pisania postów.

Brak okładek filmów 2016/05/15 22:03 #13608

Witam.
Mam też mały problem. Mam całą bibliotekę zrobioną za pomocą XTB. Wszystko jest pięknie ale nie podobają mi się niskiej jakości fanarty z filmwebu. Zainstalowałem sobie Artwork Downloader i nim zeskanowałem swoją bibliotekę. Niestety maleńki procent mojej biblioteki został zmieniony przez ten plugin. Niby poustawiałem pod siebie i ustawiłem preferowany język na polski ale marnie to wygląda. Nie wiecie na jakiej podstawie on przeszukuje bazę? Na podstawie nfo czy innej?
Administrator wyłączył możliwość publicznego pisania postów.
Moderatorzy: Regss, zet120, Admin
Zasilane przez Forum Kunena :: Diseño Zaragoza

Aby kontynuować, pokaż nam kim jesteś