KODI Fanklub Polska

Witamy, Gość
Nazwa użytkownika: Hasło: Zapamiętaj mnie

TEMAT: Brak modułu 'scriptID' padły skrypty

Brak modułu 'scriptID' padły skrypty 2013/11/11 22:01 #6627

  • jakobs84
  • Junior
  • jakobs84
  • Offline
  • Postów: 36
  • Pomógł: 2

  • KODI: 13.1
  • OS: Ubuntu 14.1
  • NAS: NIE
  • MySQL: NIE
  • Sterowanie: Medion or28v
  • HTPC: HP T5740e & HD Crystal Decoder BCM970015 + SSHD
Witam

Od wczoraj padł mi LcdProc pod XBMC nie wyświetla nic poza ekranem startowym :|

Z logu wynika brak 'scriptID',
 
21:46:52 T:2742074176  NOTICE: Thread XBPyThread start, auto delete: false
21:46:52 T:2990132032   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <type 'exceptions.AttributeError'>
Error Contents: 'module' object has no attribute 'scriptID'
Traceback (most recent call last):
 
   File "/home/xbmc/.xbmc/addons/script.xbmc.lcdproc/lcdmain.py", line 38, in <module> from settings import *
   File "/home/xbmc/.xbmc/addons/script.module.sd-xbmc/lib/settings.py", line 5, in <module> import pLog
   File "/home/xbmc/.xbmc/addons/script.module.sd-xbmc/lib/pLog.py", line 4, in <module>
 
scriptID = sys.modules[ "__main__" ].scriptID
AttributeError: 'module' object has no attribute 'scriptID'
-->End of Python script error report<--

nie mogę doszukać się rozwiązania może ktoś pomoże. Oraz cały LOG
Ostatnio zmieniany: 2013/11/11 22:06 przez jakobs84.
Administrator wyłączył możliwość publicznego pisania postów.

Brak modułu 'scriptID' padły skrypty 2013/11/16 13:04 #6653

  • jjmm
  • Junior
  • jjmm
  • Offline
  • Postów: 7
  • Pomógł: 0

Witam,
Mam podobny problem jw. Czy ktoś może z Was wie jak rozwiązać ten problem...?

Pozdrawiam
MM



Administrator wyłączył możliwość publicznego pisania postów.

Brak modułu 'scriptID' padły skrypty 2013/11/16 13:20 #6654

  • Zbychu
  • Senior
  • Zbychu
  • Offline
  • Postów: 871
  • Pomógł: 74

  • KODI: Najnowsza Beta
  • OS: OpenElec, W7-64
  • NAS: TAK
  • MySQL: TAK
  • Sterowanie: Piloty: Logitech 300i, Medion x10, Key: Logitech k400, Android Remore: Yatse
  • HTPC: 2xPC + RPi, czasem Android
No nie jestem pewien czy to faktycznie lcdproc...

A jezeli wyrzucisz dodatki sd-xbmc to również nie dziala ?
Administrator wyłączył możliwość publicznego pisania postów.
Za tę wiadomość podziękował(a): jjmm

Brak modułu 'scriptID' padły skrypty 2013/11/16 15:06 #6657

  • jjmm
  • Junior
  • jjmm
  • Offline
  • Postów: 7
  • Pomógł: 0

Faktycznie, pomogło wywalenie script.module.sd-xbmc

Dziękuję
MM
Administrator wyłączył możliwość publicznego pisania postów.

Brak modułu 'scriptID' padły skrypty 2013/11/17 16:24 #6669

  • jakobs84
  • Junior
  • jakobs84
  • Offline
  • Postów: 36
  • Pomógł: 2

  • KODI: 13.1
  • OS: Ubuntu 14.1
  • NAS: NIE
  • MySQL: NIE
  • Sterowanie: Medion or28v
  • HTPC: HP T5740e & HD Crystal Decoder BCM970015 + SSHD
Ma ktoś pomysł jak wy-edytować

lcdproc.py aby się nie gryzło ??

log wskazuje na linijkę 9 czyli import ustawień o ile się nie myle
__settings__   = xbmcaddon.Addon(id='script.xbmc.lcdproc')
__cwd__        = __settings__.getAddonInfo('path')
__icon__       = os.path.join(__cwd__,"icon.png")
__scriptname__ = "XBMC LCDproc"
 
BASE_RESOURCE_PATH = xbmc.translatePath( os.path.join( __cwd__, 'resources', 'lib' ) )
sys.path.append (BASE_RESOURCE_PATH)
 
from settings import *
from lcdproc import *
from infolabels import *
 

cały plik lcdmain.py GitHub lcdmain.py
Administrator wyłączył możliwość publicznego pisania postów.

Brak modułu 'scriptID' padły skrypty 2013/11/17 22:34 #6682

  • Zbychu
  • Senior
  • Zbychu
  • Offline
  • Postów: 871
  • Pomógł: 74

  • KODI: Najnowsza Beta
  • OS: OpenElec, W7-64
  • NAS: TAK
  • MySQL: TAK
  • Sterowanie: Piloty: Logitech 300i, Medion x10, Key: Logitech k400, Android Remore: Yatse
  • HTPC: 2xPC + RPi, czasem Android
SD XBMC tutaj nie wspieramy.
Administrator wyłączył możliwość publicznego pisania postów.

Brak modułu 'scriptID' padły skrypty 2013/11/18 00:50 #6686

  • jakobs84
  • Junior
  • jakobs84
  • Offline
  • Postów: 36
  • Pomógł: 2

  • KODI: 13.1
  • OS: Ubuntu 14.1
  • NAS: NIE
  • MySQL: NIE
  • Sterowanie: Medion or28v
  • HTPC: HP T5740e & HD Crystal Decoder BCM970015 + SSHD
Zbychu napisał:
SD XBMC tutaj nie wspieramy.

Kolega nie zauważył że modyfikacja dotyczy LcdProc a nie SD chyba że się mylę ??? Wiec nie do końca rozumiem o jakim wsparciu mowa dla SD ale jeśli to narusza regulamin mogę usunąć ten wpis. Przy okazji kombinuje nad Modem tej wtyczki i obsługą Digitemp'a ale to już inna historia.

Pozdrawiam
Ostatnio zmieniany: 2013/11/18 00:53 przez jakobs84.
Administrator wyłączył możliwość publicznego pisania postów.

Brak modułu 'scriptID' padły skrypty 2013/11/18 09:06 #6688

  • Zbychu
  • Senior
  • Zbychu
  • Offline
  • Postów: 871
  • Pomógł: 74

  • KODI: Najnowsza Beta
  • OS: OpenElec, W7-64
  • NAS: TAK
  • MySQL: TAK
  • Sterowanie: Piloty: Logitech 300i, Medion x10, Key: Logitech k400, Android Remore: Yatse
  • HTPC: 2xPC + RPi, czasem Android
Ma ktoś pomysł jak wy-edytować lcdproc.py aby się nie gryzło ??

Zrozumiałem że chodziło o "gryzienie sie" z wtyczka SD-Xbmc?
Administrator wyłączył możliwość publicznego pisania postów.

Brak modułu 'scriptID' padły skrypty 2013/11/18 17:05 #6691

  • jakobs84
  • Junior
  • jakobs84
  • Offline
  • Postów: 36
  • Pomógł: 2

  • KODI: 13.1
  • OS: Ubuntu 14.1
  • NAS: NIE
  • MySQL: NIE
  • Sterowanie: Medion or28v
  • HTPC: HP T5740e & HD Crystal Decoder BCM970015 + SSHD
Musze pokombinować jak działa

from settings import *

bo przekazywanie info z digitemp'a praktycznie już dział
Administrator wyłączył możliwość publicznego pisania postów.
Moderatorzy: Regss, zet120, Admin
Zasilane przez Forum Kunena :: Diseño Zaragoza

Aby kontynuować, pokaż nam kim jesteś