KODI Fanklub Polska

Witamy, Gość
Nazwa użytkownika: Hasło: Zapamiętaj mnie

TEMAT: WASAPI, a nie DirectSound

WASAPI, a nie DirectSound 2013/11/17 11:18 #6664

  • kicek99
  • Junior
  • kicek99
  • Offline
  • Postów: 7
  • Pomógł: 1

Witam :)
Czy da się coś zrobić , żeby dźwięk w XBMC 13 ustawić na stałę w trybie WASAPI , bo po ponownym włączeniu komputera i amplitunera ustawienia powracają do trybu DirectSound, a wtedy dźwięk w formacie DTS HD Master nie jest słyszalny - w XBMC/system//wyjście audio/ - /wyjściowe urządzenie audio/ trzeba ręcznie przestawić na / WASAPI: HDMI- Yamaha-(Intel Audio dla ekranów)/.
HTCP ( Intel dh57jg) ze zintegrowaną kartą Intel Audio dla ekranów (najnowsze sterowniki Intel) i windows 7 jest podłączony kablem HDMI do ampli Yamaha RX 467 , a ten HDMI zwrotnym do TV Panasonic.
Co jest przyczyną samoistnej zmiany ustawień dźwięku w XBMC z WASAPI na DirectSound: komputer, Windows, XBMC 13 czy coś innego ?.Przerabiałem wszystkie możliwe ustawienia dźwięku w panelu sterowania i w XBMC.
Ostatnio zmieniany: 2013/11/20 23:44 przez kicek99.
Administrator wyłączył możliwość publicznego pisania postów.

WASAPI, a nie DirectSound 2013/11/28 22:57 #6739

  • kicek99
  • Junior
  • kicek99
  • Offline
  • Postów: 7
  • Pomógł: 1

Po wielu próbach ze sterownikami audio i różnymi ustawieniami stwierdzam , że XBMC nie do końca radzi sobie z dźwiékiem DTS HD Master. Nie portrafi utrzymać ustawień wyjściowego urządzenia audio i passthrough w trybie WASAPI i często konieczne jest przywracanie ich ręcznie. Tego niedużego w sumie , choć nieco upierdliwego problemu nie mają inne odtwarzacze m.in.Media Player Classic HC czy Windows Media Player.
Pozdrawiam :)



Ostatnio zmieniany: 2013/11/29 13:33 przez kicek99.
Administrator wyłączył możliwość publicznego pisania postów.

WASAPI, a nie DirectSound 2013/12/01 09:34 #6758

  • djwozik79
  • Bywalec
  • djwozik79
  • Offline
  • Postów: 256
  • Pomógł: 7

  • KODI: 17.1
  • OS: win7/win10/android
  • NAS: tak
  • MySQL: nie
  • HTPC: Termaltake 202, 450gts , 4gb ram, 2 x4 955/ intel stick 2/32 oraz s6 edge plus
Nie wiem czy to czasem nie wina win7 bo na takim sprawdzasz ?
W starej wersji i na xp nie było tego problemu (dzwięk dts )
Jeżeli tego nie testowałeś to spróbuj ustawić domyślne urządzenie odtwarzające optyczne lub coaxial i pociąg kabelek dodatkowy do amplitunera.
Minus tego że czasami przejmuje kontrolę nad całym systemem ten coaxial i jak jakiś iny program ma ustawione na wyjściu jakiś analog to go nie słychać. (win7)
Administrator wyłączył możliwość publicznego pisania postów.

WASAPI, a nie DirectSound 2013/12/01 15:16 #6760

  • kicek99
  • Junior
  • kicek99
  • Offline
  • Postów: 7
  • Pomógł: 1

Inne kable odpadają , bo tylko HDMI przepuszcza DTS HD Master i tylko z tym formatem XBMC 12-13 ma opisany problem. Winowajcą nie jest również Win 7 , bo WMP i MPC z K- lite Codec Pack radzą sobie zawsze prawidłowo z każdym formatem - nie "gubią" tak jak czasem XBMC zaznaczonych ustawień audio output ;)
Administrator wyłączył możliwość publicznego pisania postów.

WASAPI, a nie DirectSound 2013/12/26 23:09 #7016

  • kicek99
  • Junior
  • kicek99
  • Offline
  • Postów: 7
  • Pomógł: 1

XBMC 13 alpha10 rozwiązuje problem z zapamiętywaniem WASAPI :woohoo:
Skóra Confluence posiada 4 poziomy ustawień systemu: podstawowy,standartowy, zaawansowany i ekspert. Dwa ostatnie dają nowe możliwości konfiguracji audio. Teraz XBMC działa prawidłowo :)
Ostatnio zmieniany: 2013/12/26 23:23 przez kicek99.
Administrator wyłączył możliwość publicznego pisania postów.
Za tę wiadomość podziękował(a): Zbychu

WASAPI, a nie DirectSound 2014/02/10 23:42 #7945

  • morales
  • Junior
  • morales
  • Offline
  • Postów: 7
  • Pomógł: 0

U mnie na Asus Xonar 1.3 De Luxe po analogu wszystkie tryby audio hd hulają aż miło... Dlaczego na analogu? Otóż uważam, że jest lepiej niż po HDMI, zwłaszcza, że mogę regulować jakość wyjściowego audio. W filmach to raczej zbędne, ale jeżeli chodzi o koncerty to przydaje się.
Administrator wyłączył możliwość publicznego pisania postów.
Moderatorzy: Regss, zet120, Admin
Zasilane przez Forum Kunena :: Diseño Zaragoza

Aby kontynuować, pokaż nam kim jesteś