Scraper Filmweb.pl Lite

  • Bracky
  • Junior
  • Offline
  • Postów: 36
  • Pomógł: 0

Regss napisał:

Niestety nie mam nigdzie xbmc na ubuntu i nie mam możliwości sprawdzenia. Jednak działanie dodatków nie jest chyba zależne od systemu na jakim stoi XBMC tylko od samej aplikacji. Czasem pojawiają się problemy z naprawdę rozbudowanym dodatkami ale ze scraperem nie powinno być problemu.

Mogę przetestować, tylko niech ktoś napisze gdzie mam to wrzucić, do jakiego katalogu itd..

  • zet120
  • Moderator
  • Offline
  • Postów: 338
  • Pomógł: 36
  • KODI: 16
  • OS: Linux, Mac OS X, FreeBSD
  • Sterowanie: Pilot z Lidla – SilverCrest SFB 10.1 C3
  • HTPC: AsRock A330ION | DVBSky s960 | TBS5922
Na Win7, Lubuntu plus XBMC, Mac OSX działa, zatem i na XBMCbuntu pewnie też.
Ściągasz plik zip, a potem /Wtyczki/Instaluj z pliku zip, wskazujesz pobrany plik zip i instalacja.
Następnie Wtyczki/Pobierz Wtyczki/Filmweb-Lite Repo/O Filmie/Filmweb-lite i dalej klasycznie.

  • Bracky
  • Junior
  • Offline
  • Postów: 36
  • Pomógł: 0
Zet120 dzięki za wskazówki, wszystko działa pięknie

  • marcimix
  • Junior
  • Offline
  • Postów: 3
  • Pomógł: 0
Wtyczka zdecydowanie lepiej radzi sobie z pobieraniem opisu do filmów od alternatywy smuto, ale ma jeszcze wiele wad.
Pierwsza z nich to:

1. Scraper w rzadkich przypadkach pokazuje opis po angielsku:

2. W niektórych w ogóle nie pokazuje treści:

img89.imageshack.us/img89/1732/screenshot003ce.png
3. Czasem to nawet tytułu w nich brakuje:
img145.imageshack.us/img145/4656/screenshot005c.png

W trzecim punkcje jest także widoczna nazwa „`V for Vandetta` unmasked”. Skąd człon zdemaskowany się pojawił? W tagach jest wszystko w porządku, inne scrapery (np. z imdb) odgrzebują właściwą nazwę poprawnie.
4. Nie odnajduje także wielu filmów. Z podaną datą powstanie i oryginalnym tytułem. Tutaj imbd też świeci swoją dobrodusznością.

Przydałaby się możliwość preferowania tytułu oryginalnego czy pobieranie okładek z wydań pudełkowych.

Dzięki za wtyczkę, jest naprawdę niezłą jak na polskie opisy.:cheer:

Podałem tutaj drobne przykłady filmów i mogę podać je znacznie więcej…

  • Regss
  • MODERATOR
  • Offline
  • Postów: 584
  • Pomógł: 96
  • KODI: XBMC 13 Gotham
  • OS: Windows 7 x64
  • NAS: Nie
  • MySQL: Tak
  • Sterowanie: Medion X10, Logitech K360
Witam!
Obydwa powyższe filmy pobiera mi prawidłowo. W ciemności trzeba jedynie samemu odświeżyć i wybrać właściwy film ponieważ na Filmwebie są dwa filmy z tego samego roku. Upewnij się czy masz aktualną wersję scrapera – 1.0.6. Podaj inne tytuły z którymi masz problem.
Pozdrawiam.

  • marcimix
  • Junior
  • Offline
  • Postów: 3
  • Pomógł: 0
Tej nocy odtagowałem wszystkie swoje filmy do TMDb, dodając przy tym mnóstwo brakujących polskich rodzimych filmów, jak i opisów od dystrybutorów do zagranicznych. W sumie, wszystko pochłonęło mnie jakieś 7 szalonych godzin spędzonym przy komputerze, do jakieś 5 nad ranem:lol::lol: Wyślę Ci na pw błędne odczyty, bo .themoviedb czyta je już wszystkie. Nawet w oryginalnych tytułach i okładkach w naturalnych rozmiarach:)

  • marx
  • Autor Artykułów
  • Offline
  • Postów: 799
  • Pomógł: 43
  • KODI: 15.2
  • OS: Linux Debian
  • NAS: Nie
  • MySQL: Tak
  • Sterowanie: Logitech Harmony
Scraper fajnie działa ale nie współpracuje z pluginem traktr albo ja nie umiem czegoś ustawić. Traktr wymaga tvdbid ale nie wiem czy ten scraper go ustawia?
Czy ktoś w ogóle czyta ten wątek?

  • Regss
  • MODERATOR
  • Offline
  • Postów: 584
  • Pomógł: 96
  • KODI: XBMC 13 Gotham
  • OS: Windows 7 x64
  • NAS: Nie
  • MySQL: Tak
  • Sterowanie: Medion X10, Logitech K360
tvdbid to id dla seriali a ten scraper obsługuje filmy. Od wersji 1.0.8 którą przed chwilą uaktualniłem scraper zapisuje IMDB ID w bazie i z tego co wiem traktr je obsługuje.

  • marx
  • Autor Artykułów
  • Offline
  • Postów: 799
  • Pomógł: 43
  • KODI: 15.2
  • OS: Linux Debian
  • NAS: Nie
  • MySQL: Tak
  • Sterowanie: Logitech Harmony
No i teraz działa. Dodatkowo zastosowałem świeżutki plugin trakt z gita zamiast traktr. Dzięki!

  • mikas
  • Junior
  • Offline
  • Postów: 29
  • Pomógł: 0
Koledzy proszę o wyrozumiałość i pomoc w poniższym temacie.
Zakupiłem Raspberry Pi i zainstalowałem na nim OpenELEC oraz scraper do filmweb. Z tego co czytałem w google powinienem tera ustawić go w system-ustawienia-wideo. Ale tam nie widzę żadnego scrapera. Walczę z tym od kilku dni i nie wiem jak sobie z tym poradzić by mieć do filmów okładki i opisy.
Bardzo proszę o pomoc.

  • sluzu
  • Junior
  • Offline
  • Postów: 19
  • Pomógł: 1
  • KODI: Isengard
  • OS: Wszystkie możliwe 🙂
  • NAS: Tak
  • MySQL: Tak
  • Sterowanie: Forever SR-100
a nie lepiej użyć XBMC Toolbox ? Według mnie o wiele lepsze możliwości i możesz to spokojnie robić na innym komputerze, a potem tylko dodać do swojego Raspberry

  • mikas
  • Junior
  • Offline
  • Postów: 29
  • Pomógł: 0
sluzu napisał:

a nie lepiej użyć XBMC Toolbox ? Według mnie o wiele lepsze możliwości i możesz to spokojnie robić na innym komputerze, a potem tylko dodać do swojego Raspberry

A to się instaluje na raspberry i gdzie to znajdę ?

  • caeruleus
  • Junior
  • Offline
  • Postów: 40
  • Pomógł: 0
mikas napisał:

Koledzy proszę o wyrozumiałość i pomoc w poniższym temacie.
Zakupiłem Raspberry Pi i zainstalowałem na nim OpenELEC oraz scraper do filmweb. Z tego co czytałem w google powinienem tera ustawić go w system-ustawienia-wideo. Ale tam nie widzę żadnego scrapera. Walczę z tym od kilku dni i nie wiem jak sobie z tym poradzić by mieć do filmów okładki i opisy.
Bardzo proszę o pomoc.

Scraper ustawiasz przy wyborze źródła, z którego będą udostępniane Twoje materiały w bibliotece. Najpierw ustawiasz czy dane źródło ma być bazą dla filmów czy też dla seriali, a dalej wybierasz odpowiedni scraper.
MENU GŁÓWNE –> WIDEO –> Pliki –> Dodaj wideo

Jeżeli masz już ustawione źródło, to możesz zmienić scraper edytując je.
MENU GŁÓWNE –> WIDEO –> Pliki –> /nazwa Twojego źródła/ –> prawoklik –> Edytuj źródło

Pamiętaj, że jeżeli chcesz korzystać z opisywanego w tym wątku scrapera „Filmweb.pl-lite”, autorstwa Kolegi Regss, to musisz najpierw pobrać wtyczkę i ją zainstalować. Domyślnie dostępny jest tylko wcześniejszy scraper, oparty na Filmwebie, a mianowicie „Filmweb” by smuto, który niestety nie jest już rozwijany i po zmianach na filmweb.pl, przestał być funkcjonalny.

  • sluzu
  • Junior
  • Offline
  • Postów: 19
  • Pomógł: 1
  • KODI: Isengard
  • OS: Wszystkie możliwe 🙂
  • NAS: Tak
  • MySQL: Tak
  • Sterowanie: Forever SR-100
mikas napisał:

sluzu napisał:

a nie lepiej użyć XBMC Toolbox ? Według mnie o wiele lepsze możliwości i możesz to spokojnie robić na innym komputerze, a potem tylko dodać do swojego Raspberry

A to się instaluje na raspberry i gdzie to znajdę ?

Link

Chodzi o to że ten XBMC Toolbox tworzy w folderze z filmami pliki, dzięki którym w razie awarii bazy filmów, zawsze można ją bezproblemowo wczytać bez użycia internetu.
Minus jest taki (o ile można to uznać za minus), że potrzeba jakiegoś komputera z Windows i XBMC, ażeby móc działać na XBMC Toolbox. Przyznam szczerze, że sam byłem sceptycznie do tego narzędzia nastawiony, ale teraz nie wyobrażam sobie, żebym mógł filmy dodawać inaczej;)

  • marx
  • Autor Artykułów
  • Offline
  • Postów: 799
  • Pomógł: 43
  • KODI: 15.2
  • OS: Linux Debian
  • NAS: Nie
  • MySQL: Tak
  • Sterowanie: Logitech Harmony
Mam problem z wiki.xbmc.org/index.php?title=Movie_Sets Włączyłem w opcjach, dodałem od nowa pliki, zdrapały się, ale nadal jak wchodzę w biblioteka->Filmy->Gatunek itp, to filmy mam niepogrupowane w zestawy.
Albo coś źle robię, albo scraper nie potrafi odczytać informacji o zestawach i nie dodaje ich do biblioteki.

  • caeruleus
  • Junior
  • Offline
  • Postów: 40
  • Pomógł: 0
Niestety grupowanie filmów w zestawy z automatu przez XBMC, nie jest doskonałe. Nie zawsze się to w ogóle udaje, albo często nie w taki sposób jak byśmy sobie tego życzyli. Zdarza się, że tworzy kolekcje z filmów nie tylko pod względem jakiejś konkretnej serii, ale grupuje je np. ze względu na producenta albo aktora. Z moich własnych doświadczeń: część kreskówek jako „Disney Collection” tudzież „Nicolas Cage Collection”.

Jest na to kilka sposobów, szczegółowo zostało to opisane tutaj.

Najprostsze wydaje się użycie wspominanego już XTB lub edycja przez przeglądarkę. Ja osobiście preferuję ten drugi sposób. Szerzej w tym artykule.

  • caeruleus
  • Junior
  • Offline
  • Postów: 40
  • Pomógł: 0
Info dla Kolegi Regss.

Od pewnego czasu znów pojawił się problem z naszymi rodzimymi znakami, a konkretnie z literką „ó” i niektórymi znakami interpunkcyjnymi – np. „-„(myślnik). Wywala krzaki. Co ciekawe dzieje się tak tylko w opisie głównym, w tkzw. opisie krótkim tego samego filmu jest OK.
Przykłady poniżej:

  • Regss
  • MODERATOR
  • Offline
  • Postów: 584
  • Pomógł: 96
  • KODI: XBMC 13 Gotham
  • OS: Windows 7 x64
  • NAS: Nie
  • MySQL: Tak
  • Sterowanie: Medion X10, Logitech K360
Hmm.. przed chwilą sprawdzałem i u mnie wszystko jest ok. Masz najnowszą wersję 1.0.8?

  • marx
  • Autor Artykułów
  • Offline
  • Postów: 799
  • Pomógł: 43
  • KODI: 15.2
  • OS: Linux Debian
  • NAS: Nie
  • MySQL: Tak
  • Sterowanie: Logitech Harmony
Filmweb ma coś takiego jak powiązane tytuły. Nie da się tego użyć do tworzenia zestawów?

  • caeruleus
  • Junior
  • Offline
  • Postów: 40
  • Pomógł: 0
Regss napisał:

Hmm.. przed chwilą sprawdzałem i u mnie wszystko jest ok. Masz najnowszą wersję 1.0.8?

Jak najbardziej

Po Twoim poście odświeżyłem ponownie screenowane wyżej pozycje i nadal jest to samo. Tylko kurcze, jeżeli u Ciebie jest dobrze, a u mnie nie, to w czym jest problem? Masz jakiś koncept?

Wątek odtworzony z archiwalnej wersji strony.

Dodaj komentarz

Twój adres e-mail nie zostanie opublikowany.

Related Posts

Begin typing your search term above and press enter to search. Press ESC to cancel.