[Kodi 15.1] Laptop + karta USB Creative SB X-Fi 5.1 Surround – po jakimś czasie zawiesza dźwięk w całym systemie

  • WSZR
  • OFFLINE
  • Junior
    Junior
  • Postów: 38
  • Oklaski: 1
  • KODI:
Witajcie.
Zacznę od konfiguracji, potem od tego, co próbowałem.
Kupiłem nowego laptopa z portami USB 3.0, do którego podłączyłem zewnętrzną kartę dźwiękową Creative SoundBlaster X-Fi 5.1 Surround (bez PRO) na USB. Jestem zmuszony podłączać ją pod USB 3.0, i normalnie nie ma z tym żadnych problemów, gra normalnie, poprawnie. Głośniki mam 5.1, i z tylu kanałów korzystam.
Problem pojawia się, gdy chcę korzystać z Kodi. Przez jakiś czas dźwięk normalnie jest odtwarzany, po czym po jakimś czasie dźwięk się zawiesza, i to w całym systemie, muszę wypiąć i wpiąć, żeby dźwięk był odtwarzany, i tak w kółko, ale nieregularnie.
Problem występuje tylko przy Kodi, i chyba tylko przy USB 3.0, na USB 2.0 dźwięk się nie zawiesił przez dłuższy czas, ale jestem zmuszony korzystać z portu USB 3.0. Przy Youtube czy Foobar2000 nie ma tego zjawiska.
Próbowałem instalować na nowo sterowniki USB 3.0 oraz karty dźwiękowej (trzy wersje, na WIN7, z którego nadal korzystam).
Bawiłem się ustawieniami karty dźwiękowej, w sumie dużo nie ma, zaledwie zmiana USB z Full Speed na High Speed, i odwrotnie, tyle. Reszta to konfiguracja związana z dźwiękiem. W samych ustawieniach sterownika czy portów też nie ma żadnych opcji, próbowałem zmieniać opcje związane z oszczędzaniem energii, też nic.
Próbowałem zmieniać też ustawienia w Kodi, ale nie znalazłem rozwiązania. Na Wasabi niby gra ciągle, ale to wygląda jak w przypadku Direct, czyli po jakimś czasie rwie dźwięk, przerywa, tylko w przypadku Wasabi dźwięk powraca bez konieczności wypinania karty. Zmiana konfiguracji odtwarzania, jakości próbkowania czy podtrzymywania aktywności urządzenia odtwarzania niczego nie zmienia.
Wygląda jakby zapełniał się jakiś bufor i potem zawieszał kartę, ale to tylko moje spekulacje.
Ktoś ma jakiś pomysł?

  • Piter
  • OFFLINE
  • Autor Artykułów
    Autor Artykułów
  • Postów: 448
  • Oklaski: 12
  • KODI: Helix
  • W7, OpenElec
Próbowałeś inne wersje Kodi ?
Sprawdzales logi Kodi ?

  • WSZR
  • OFFLINE
  • Junior
    Junior
  • Postów: 38
  • Oklaski: 1
  • KODI:
Kompletnie zapomniałem o logu, dzięki za podpowiedź, jak zwykle najbardziej trywialny pomysł umyka. Końcówka logu przed wywaleniem dźwięku:

15:29:42 T:9184 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer15:30:18 T:8816 WARNING: Previous line repeats 2 times.15:30:18 T:8816   ERROR: CDVDAudio::AddPacketsRenderer - timeout adding data to renderer15:30:21 T:8816   ERROR: Previous line repeats 2 times.15:30:21 T:8816  NOTICE: CDVDPlayerAudio::OutputPacket skipping a packets of duration 2115:30:22 T:8816  NOTICE: Previous line repeats 163 times.15:30:22 T:8816   ERROR: CDVDAudio::AddPacketsRenderer - timeout adding data to renderer15:30:22 T:8816  NOTICE: CDVDPlayerAudio::OutputPacket skipping a packets of duration 2115:30:23 T:8816  NOTICE: Previous line repeats 55 times.15:30:23 T:8816   ERROR: CDVDAudio::AddPacketsRenderer - timeout adding data to renderer15:30:23 T:8816  NOTICE: CDVDPlayerAudio::OutputPacket skipping a packets of duration 2115:30:24 T:8816  NOTICE: Previous line repeats 54 times.15:30:24 T:8816   ERROR: CDVDAudio::AddPacketsRenderer - timeout adding data to renderer15:30:24 T:8816  NOTICE: CDVDPlayerAudio::OutputPacket skipping a packets of duration 2115:30:25 T:8816  NOTICE: Previous line repeats 55 times.15:30:25 T:8816   ERROR: CDVDAudio::AddPacketsRenderer - timeout adding data to renderer15:30:25 T:8816  NOTICE: CDVDPlayerAudio::OutputPacket skipping a packets of duration 21

Nic mi to nie mówi, Google już coś więcej podpowiedziało, czyli ten wątek: forum.kodi.tv/showthread.php?tid=225898

W załączniku dodałem pełny log zaraz po wywaleniu dźwięku w przed chwilą zainstalowanej wersji 15.2 rc1.

Kolejne moje spostrzeżenie to dzieje się tak przy materiałach wykorzystujących AVC1 (np. materiały z Youtube, Ipli czy Player.pl).

This message has an attachment file.
Please log in or register to see it.

  • WSZR
  • OFFLINE
  • Junior
    Junior
  • Postów: 38
  • Oklaski: 1
  • KODI:
Cholera, nie mogę znaleźć rozwiązania. Instalowałem różne wersje, 14.2, 15, 15.1, 15.2 rc1 i 16 monthly. Przeglądałem wiele wątków wklejając w Google linijki z konkretnym komunikatem i jedyne co się dowiedziałem to to, że to właśnie ze strumieniami jest problem, w moim przypadku wcześniej wymienione Youtube, Ipla czy Player.pl. Niby oznaczone są jako rozwiązane, ale albo nie rozumiem o co chodzi, albo na inny system, czego nie potrafię przełożyć na Windowsa, a i język angielski nie pomaga, albo też niektórym wystarczyła aktualizacja. Poczułem bezsilność.
Na USB 2.0 na pewno w logach nie ma tych komunikatów i błędów:

ERROR: CDVDAudio::AddPacketsRenderer - timeout adding data to rendererNOTICE: CDVDPlayerAudio::OutputPacket skipping a packets of duration 21

Próbowałem samodzielnie zwiększyć bufor dla zasobów z sieci w pliku advancedsettings.xml, ale też bez zmian.
Tutaj pewnie jest bardziej bezinteresowna pomoc niż osoby znające na wylot Kodi, chyba będę musiał napisać na forum Kodi.tv.

Wątek odtworzony z archiwalnej wersji strony.

Dodaj komentarz

Twój adres e-mail nie zostanie opublikowany.

Related Posts

Begin typing your search term above and press enter to search. Press ESC to cancel.